FastFieldSolvers Forum
FastFieldSolvers Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
 All Forums
 FastFieldSolvers
 FasterCap and FastCap2
 Installing wxWidgets (wxGTK), for FasterCap
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

cyberduke

5 Posts

Posted - Jan 01 2021 :  15:44:24  Show Profile  Reply with Quote
Hi, I am runnung Ubuntu 20, and trying to install FasterCap, apon using I get the error
quote:
./FasterCap: error while loading shared libraries: libwx_gtk2u_core-3.0.so.0: cannot open shared object file: No such file or directory



but I have already installed it, as shown by this message when trying to install it:
quote:

libwxbase3.0-0v5 is already the newest version (3.0.4+dfsg-15build1).
libwxbase3.0-0v5 set to manually installed.



Maybe I installed it wrong, I would appreciate any assistance. Thank you.


cyberduke

5 Posts

Posted - Jan 04 2021 :  21:25:46  Show Profile  Reply with Quote
So in Ubuntu 20 libwxgtk3.0-0v5 was renamed to libwxgtk3.0-gtk3-0v5, maybe this name change is causing the problem?

Thanks in advance
Go to Top of Page

Enrico

447 Posts

Posted - Jan 09 2021 :  19:23:48  Show Profile  Reply with Quote
Last Ubuntu we tested was 16. It can well be that the library changed. I n this case your only option is to recompile FasterCap on the target machine using the sources. I see that you opened an issue on git; but it should not apply to the source code, only to binaries.

Best,
Enrico
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
FastFieldSolvers Forum © 2020 FastFieldSolvers S.R.L. Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.06